Keboola - Snowflake Writer — Data Type Length Bug Fix (All Stacks) – Incident details

Snowflake Writer — Data Type Length Bug Fix (All Stacks)

Resolved
Degraded performance
Started 2 months agoLasted 2 days

Affected

AWS EU (eu-central-1)

Degraded performance from 3:10 PM to 3:45 PM

GCP EU (europe-west3)

Degraded performance from 3:10 PM to 3:45 PM

AWS US (us-east-1)

Degraded performance from 3:10 PM to 3:45 PM

GCP US (us-east4)

Degraded performance from 3:10 PM to 3:45 PM

Azure NE (north-europe)

Degraded performance from 3:10 PM to 3:45 PM

Updates
  • Resolved
    Resolved

    The fix is now deployed (writer version 4.5.0). Full load configurations will self-heal automatically on the next run. Where manual intervention is needed, we will reach out to affected customers directly.

    We apologize for the inconvenience. If you have any questions, please contact our support team.

  • Identified
    Identified

    We identified a bug in the Snowflake writer UI that affected numeric data type length settings for configurations created or tables added between December 16, 2025 and February 12, 2026. Custom numeric type lengths were silently reset to Snowflake defaults.

    For example, a DECIMAL(18,2) would become DECIMAL(38,0), effectively losing decimal precision.

    What is NOT affected

    Data Gateway, all Snowflake extractors and transformations, and data stored in Keboola Storage are not impacted by this issue.