Keboola - Inconsistencies affecting Flow jobs in all Azure stacks – Incident details
All systems operational
Inconsistencies affecting Flow jobs in all Azure stacks
Resolved
Degraded performance
Started 8 days agoLasted about 1 hour
Affected
Azure NE (north-europe)
Degraded performance from 6:15 AM to 7:35 AM
Updates
Update
Update
We have identified multiple Storage jobs stuck in a processing state, blocking downstream jobs from proceeding. All of them have been terminated, and job processing should now be unblocked.
We apologize for any inconvenience this may have caused.
Resolved
Resolved
The issue affecting stuck flow jobs has been resolved, and normal operation has been restored.
We apologize for any inconvenience this may have caused.
Identified
Identified
We have identified the root cause as database inconsistency. Only a low number of flow jobs are stuck in processing state despite all their child jobs are finished (mostly failed). Our team is now working on implementing a solution.
We apologize for the disruption and will provide an update within 1 hour or when new information is available.
Investigating
Investigating
We are currently investigating reports of inconsistent flow jobs. Some users may be experiencing stuck flows.
Our team has been notified and is actively investigating.
Next update in 30 minutes or when new information is available.