Keboola - Keboola MCP not showing all available tools – Incident details

Keboola MCP not showing all available tools

Resolved
Operational
Started about 1 month agoLasted 32 minutes

Affected

AWS EU (eu-central-1)

Degraded performance from 10:33 PM to 11:05 PM

GCP EU (europe-west3)

Degraded performance from 10:33 PM to 11:05 PM

AWS US (us-east-1)

Degraded performance from 10:33 PM to 11:05 PM

GCP US (us-east4)

Degraded performance from 10:33 PM to 11:05 PM

Azure NE (north-europe)

Degraded performance from 10:33 PM to 11:05 PM

Updates
  • Resolved
    Resolved

    It seems that reauthorizing the MCP server resolves the issue. If you are experiencing missing or limited tools, please disconnect and reconnect the MCP server in your client. We are continuing to investigate the root cause to prevent recurrence.

  • Update
    Update

    Kai assistant (and other forms of platform chats) are not affected by this issue. Only external use of the MCP server (e. g. in Claude) are affected.

  • Investigating
    Investigating

    We have detected an issue with our MCP server that under some circumstances shows only run_sync_action tool or does not show any tools at all. Our engineering team is investigating the issue with high priority.

    We apologize for the disruption and will provide an update when new information is available.