Keboola - Kai Assistant — elevated error rates – Incident details

Kai Assistant — elevated error rates

Resolved
Partial outage 10 %
Started about 2 months agoLasted about 18 hours

Affected

AWS EU (eu-central-1)

Partial outage from 2:22 PM to 8:18 PM, Operational from 8:18 PM to 8:25 AM

GCP EU (europe-west3)

Partial outage from 2:22 PM to 8:18 PM, Operational from 8:18 PM to 8:25 AM

Azure NE (north-europe)

Partial outage from 2:22 PM to 8:18 PM, Operational from 8:18 PM to 8:25 AM

Updates
  • Resolved
    UTC
    Resolved

    Kai Assistant has returned to normal operation. We are no longer observing errors related to the upstream AI provider capacity constraints, and chat and suggestion requests are completing successfully.

  • Investigating
    UTC
    Investigating

    We are currently observing elevated error rates with Kai Assistant on our EU stacks. A portion of chat messages and suggestions are failing due to temporary capacity constraints with an upstream AI provider.

    Affected functionality: Kai Assistant chat responses and suggestions.

    The issue is intermittent — many requests still succeed, but retries may be needed. Our team is actively monitoring the situation. No action is required from customers.

    We will provide an update as the situation improves.