Keboola - Google Ads data source jobs failing – Incident details

Google Ads data source jobs failing

Resolved
Degraded performance
Started 18 days agoLasted about 3 hours

Affected

AWS EU (eu-central-1)

Degraded performance from 9:28 AM to 12:14 PM

GCP EU (europe-west3)

Degraded performance from 9:28 AM to 12:14 PM

AWS US (us-east-1)

Degraded performance from 9:28 AM to 12:14 PM

GCP US (us-east4)

Degraded performance from 9:28 AM to 12:14 PM

Azure NE (north-europe)

Degraded performance from 9:28 AM to 12:14 PM

Updates
  • Update
    UTC
    Update

    Troubleshooting - extra column case:

    In some cases we experience that while the component was returning errors, some jobs completed but wrote extra, invalid columns into the destination table. After the fix, those columns are no longer returned and such jobs may fail on a column mismatch.

    If this affects you, drop the extra columns that were not present in the table before the incident, then re-run the configuration to backfill today's and yesterday's data. If problems persist, please contact our support.

  • Resolved
    UTC
    Resolved

    The fix has been released, the Google Ads data source now uses a supported Google Ads API version and configurations should run normally again.

    We recommend re-running your Google Ads configurations to backfill data for today and yesterday. If you still experience failures, please contact our support.

  • Monitoring
    UTC
    Monitoring

    We have identified the cause and are rolling out a fix to the Google Ads data source that upgrades it to a supported Google Ads API version. We are monitoring the rollout and job results

  • Investigating
    UTC
    Investigating

    We have detected an issue with the Google Ads data source affecting all projects that use it. Google has stopped accepting requests to the Google Ads API version currently used by the component, so extraction jobs fail with an UNSUPPORTED_VERSION error. Our engineering team is working on the upgrade with high priority.

    We apologize for the disruption and will provide an update within 1 hour or when new information is available.