Keboola - Issues with KAI assistant approvals – Incident details

Issues with KAI assistant approvals

Resolved
Major outage
Started 13 days agoLasted about 3 hours

Affected

AWS EU (eu-central-1)

Degraded performance from 8:00 AM to 10:08 AM, Operational from 10:08 AM to 10:44 AM

GCP US (us-east4)

Degraded performance from 8:00 AM to 10:08 AM, Operational from 10:08 AM to 10:44 AM

Updates
  • Update
    Update

    This incident has been resolved.

    Few chats started approximately between 6:30 UTC and 8:30 UTC may still show the errors below, if you encounter these, please start a new chat.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have identified the root cause and deployed a fix. Please start a new fresh conversation in case you see any of the error messages:

    messages.4: user messages must have non-empty content
    messages.11.content.1.text: cache_control cannot be set for empty text blocks
  • Update
    Update
    We are currently investigating this incident.
  • Investigating
    Investigating

    We are currently investigating issues with failing action approvals with KAI assistant in GCP US stack.