Keboola - Storage jobs slowdown on Snowflake Multitenant stacks – Incident details

Storage jobs slowdown on Snowflake Multitenant stacks

Resolved
Degraded performance
Started 3 months agoLasted about 18 hours

Affected

AWS EU (eu-central-1)

Degraded performance from 9:02 AM to 2:45 PM, Operational from 2:45 PM to 3:07 AM

GCP EU (europe-west3)

Degraded performance from 9:02 AM to 2:45 PM, Operational from 2:45 PM to 3:07 AM

AWS US (us-east-1)

Degraded performance from 9:02 AM to 2:45 PM, Operational from 2:45 PM to 3:07 AM

GCP US (us-east4)

Degraded performance from 9:02 AM to 2:45 PM, Operational from 2:45 PM to 3:07 AM

Azure NE (north-europe)

Degraded performance from 9:02 AM to 2:45 PM, Operational from 2:45 PM to 3:07 AM

Updates
  • Resolved
    Resolved

    The root cause is fixed and the transformations on different backend size than default and performance seems to be on track as it was before.

  • Monitoring
    Monitoring

    We have released fix, which seems to be working correctly. We will continue monitoring the situation that the performance of transformations is back on track as before.

  • Investigating
    Investigating

    We are investigating issues with slowdown of Storage jobs on Multitenant stacks. There are affected projects which are using Snowflake (Bigquery not affected). Issue was firstly noted on 10.07.2025.

    The issue has impact on transformations with bigger backend size than default. 

    We are preparing fix so the jobs are running as before.