Keboola - GCP EU stuck storage jobs – Incident details

GCP EU stuck storage jobs

Resolved
Degraded performance
Started about 1 month agoLasted about 12 hours

Affected

GCP EU (europe-west3)

Degraded performance from 9:37 PM to 9:51 AM

Updates
  • Resolved
    Resolved

    The issue affecting storage jobs has been fully resolved.

    All functionality has been restored, and the root cause has been identified.

    We apologize for the inconvenience caused. Our team is preparing preventive actions to ensure this does not recur.

    Thank you for your patience while we worked to resolve this issue.

  • Update
    Update

    We noticed another stuck storage job in one of the originally affected projects. We are investigating the situation further.

  • Investigating
    Investigating

    We are aware of an issue affecting storage jobs in the GCP EU stack.

    Symptoms:

    • Stuck storage jobs

    • Delayed or incomplete job execution

    At Nov 2, 2025, 7:16 PM CET, we received two support tickets indicating stuck storage jobs. The issue initially appeared localized, but as the root cause could not be confirmed, we are issuing this notice retrospectively.

    We have verified that there are currently no other stuck storage tasks in the stack. If you notice any unusual behavior, please contact support.

    Our team continues to monitor the situation.

    Next update: tomorrow morning or earlier if new information becomes available.